Inicio > CCNA, Cisco, Protocolo de Enrutamiento, Redes, RIPv1 > RIP versión 1 (RIPv1)

RIP versión 1 (RIPv1)

Antes de mostrarles cómo configurar RIP voy a detenerme un poco en la teoría. RIP es un protocolo de enrutamiento de puerta de enlace interna (IGP – Internal Gateway Protocol) basado en un protocolo original de Xerox, el GWINFO. Este protocolo pasó por varias modificaciones y versiones anteriores, pero RIP perduró debido a su implementación junto a TCP/IP, su sencillez de configuración y compatibilidad. Hoy en día hay 3 versiones: RIPv1, RIPv2 y RIPng.

RIPv1: La versión 1 del protocolo de enrutamiento RIP es “con clase”, es decir que no soporta subredes, VLSM ni CIDR, no posee mecanismos de autenticación y no realiza actualizaciones desencadenadas por eventos. Todas estas limitaciones hicieron que con el paso del tiempo y las nuevas necesidades cayera en desuso.

RIPv2: La versión 2 del protocolo de enrutamiento RIP es “sin clase”, soporta subredes, VLSM, CIDR, resumen de rutas, posee mecanismos de autenticación mediante texto plano o codificación MD5, realizaactualizaciones desencadenadas por eventos.

RIPng: La versión ng del protocolo de enrutamiento RIP es para implementaciones IPv6.

RIP es un protocolo de enrutamiento con una distancia administrativa de 120 (recuerden que cuanto menor sea la distancia administrativa el protocolo se considera más confiable) y utiliza un algoritmo de vector distancia utilizando como métrica el número de saltos. Al carecer de otro mecanismo para evitar loops posee una métrica de 15 saltos, tomando al salto 16 como infinito y marcándolo como inalcanzable en la tabla de enrutamiento. Otra característica de RIP es que permite balanceo de carga en 6 rutas de igual costo, 4 por defecto.

RIP actualiza cada 30 segundos utilizando el protocolo UDP y el puerto 520, enviando la tabla de enrutamiento completa a sus vecinos. RIPv2 realiza actualizaciones desencadenadas por eventos. Las rutas tienen un TTL (tiempo de vida) de 180 segundos, es decir que si en 6 intercambios la ruta no aparece activa, esta es borrada de la tabla de enrutamiento.

Sigan leyendo para ver cómo se configura RIP.

Configurar RIP (Configuración Básica)

RIP es muy fácil de configurar así que no creo que tengan problemas. Cualquier cosa o duda me consultan.

Router> enable

Router# config terminal

Router(config)# router rip

Router(config-router)# network 10.0.0.0
(publicamos la red directamente conectada)

Router(config-router)# network 172.16.0.0
(publicamos la red directamente conectada)

Router(config-router)# version 2
(habilitamos la versión 2 de RIP)

Ejemplo:

Configuración de protocolo RIP

Configuración router Tredstone 1:

Router>enable

Router#config terminal

Router(config)#hostname tredstone1

tredstone1(config)#interface s0/0

tredstone1(config-if)#ip address 200.0.0.1 255.255.255.0

tredstone1(config-if)#clock rate 56000

tredstone1(config-if)#no shutdown

tredstone1(config-if)#exit

tredstone1(config)#interface f0/0

tredstone1(config-if)#ip address 192.168.0.1 255.255.255.0

tredstone1(config-if)#no shutdown

tredstone1(config-if)#exit

tredstone1(config)#router rip

tredstone1(config-router)#network 200.0.0.0

tredstone1(config-router)#network 192.168.0.0

Configuración router Tredstone 2

Router>enable

Router#config terminal

Router(config)#hostname tredstone2

tredstone2(config)#interface s0/1

tredstone2(config-if)#ip address 200.0.0.2 255.255.255.0

tredstone2(config-if)#no shutdown

tredstone2(config-if)#exit

tredstone2(config)#interface s0/0

tredstone2(config-if)#ip address 201.0.0.1 255.255.255.0

tredstone2(config-if)#clock rate 56000

tredstone2(config-if)#no shutdown

tredstone2(config-if)#exit

tredstone2(config)#interface f0/0

tredstone2(config-if)#ip address 193.168.0.1 255.255.255.0

tredstone2(config-if)#no shutdown

tredstone2(config-if)#router rip

tredstone2(config-router)#network 200.0.0.0

tredstone2(config-router)#network 201.0.0.0

tredstone2(config-router)#network 193.168.0.0

Configuración router Tredstone 3:

Router>enable

Router#config terminal

Router(config)#interface s0/1

Router(config-if)#ip address 201.0.0.2 255.255.255.0

Router(config-if)#no shutdown

Router(config)#interface f0/0

Router(config-if)#ip address 194.168.0.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#network 201.0.0.0

Router(config-router)#network 194.168.0.0

Tabla de enrutamiento comando show ip route en el router tredstone 1

C    192.168.0.0/24 is directly connected, FastEthernet0/0
R    193.168.0.0/24 [120/1] via 200.0.0.2, 00:00:28, Serial0/0
R    194.168.0.0/24 [120/2] via 200.0.0.2, 00:00:28, Serial0/0
C    200.0.0.0/24 is directly connected, Serial0/0
R    201.0.0.0/24 [120/1] via 200.0.0.2, 00:00:28, Serial0/0

Tabla de enrutamiento comando show ip route en el router tredstone 2

R    192.168.0.0/24 [120/1] via 200.0.0.1, 00:00:05, Serial0/1
C    193.168.0.0/24 is directly connected, FastEthernet0/0
R    194.168.0.0/24 [120/1] via 201.0.0.2, 00:00:11, Serial0/0
C    200.0.0.0/24 is directly connected, Serial0/1
C    201.0.0.0/24 is directly connected, Serial0/0

Tabla de enrutamiento comando show ip route en el router tredstone 3

R    192.168.0.0/24 [120/2] via 201.0.0.1, 00:00:07, Serial0/1
R    193.168.0.0/24 [120/1] via 201.0.0.1, 00:00:07, Serial0/1
C    194.168.0.0/24 is directly connected, FastEthernet0/0
R    200.0.0.0/24 [120/1] via 201.0.0.1, 00:00:07, Serial0/1
C    201.0.0.0/24 is directly connected, Serial0/1

Fuente: http://tredstone.wordpress.com/2010/01/06/configuracion-protocolo-de-enrutamiento-rip-v1/ , http://tadashikun.com/

  1. Aún no hay comentarios.
  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: